Tente 3D Wiki
Advertisement

En este tema voy a explicar como crear renders con Blender 2.83 a partir de los modelos montados con el formato LDraw. Esta nueva versión tiene algunas mejoras que no están en la 2.82. Por otro lado, las versiones 2.8 utilizan un entorno más intuitivo que el de la versiones 2.7. Un problema de las versiones 2.8 es que no funcionan con tarjetas gráficas muy viejas y entonces solo se puede usar la CPU, que suele ser mucho más lenta. En tal caso es mejor usar la versión 2.79 o bien comprar una tarjeta más moderna.

INSTALACIÓN
En primer lugar tenemos que instalar el programa libre Blender. Lo descargamos de la página oficial:
https://www.blender.org/download/
La página detectará el sistema operativo de nuestro ordenador y nos mostrará el enlace al ejecutable más adecuado. Este programa funciona en Windows, Mac, Linux y otros sistemas.

Una vez instalado Blender, la primera vez que lo ejecutemos nos preguntará varias cosas. La primera es el idioma, que cambiaremos de "English (English)" a "Spanish (Español)". La segunda opción por defecto es "Blender", pero si estamos acostumbrados a los atajos de la vieja versión 2.79 nos podría interesar cambiarlo a "Blender 27X". Este tutorial está realizado con la opción por defecto. La tercera opción es si se usa el botón izquierdo del ratón para seleccionar los elementos (por defecto) o el botón derecho, que era lo habitual en las versiones viejas (yo usaré el izquierdo). La cuarta opción determina qué sucede cuando pulsamos la barra espaciadora. En este tutorial no se usa, pero las opciones Herramienta y Búsqueda son preferibles. Por último, podemos seleccionar la combinación de colores del programa (Blender Dark por defecto), entre los cuales hay algunas de otros programas 3D para facilitar el cambio a esos usuarios. Pulsando el último botón podremos guardar estos ajustes. Pulsamos en cualquier hueco del cuadro que aparece en el centro para que se oculte. Tiene la opción de abrir un nuevo proyecto de tipo General, pero no hace falta porque ya está abierto.

Blender283-01.png

COMPLEMENTO PARA LDRAW
Para que Blender pueda cargar modelos en formato LDraw necesitamos añadirle un complemento. Entramos en la página
https://github.com/TobyLobster/ImportLDraw/releases
y hacemos clic en el enlace importldraw1.1.11_for_blender_281.zip (el más reciente a fecha actual) o bien el primero que salga en esa página si han aparecido nuevas versiones. Guardamos el fichero zip en cualquier carpeta de nuestro ordenador, por defecto será la que usa nuestro navegador para las descargas.
En Blender, entramos en el menú Editar -> Preferencias y después en la pestaña Complementos. Pulsamos el botón "Instalar...", seleccionamos el archivo zip que hemos descargado antes y pulsamos el botón "Instalar complemento". Lo siguiente es activarlo marcando la casilla que hay junto a "Import-Export: Import LDraw". Cerramos la ventana de Preferencias.

Blender283-02.png



ABRIR FICHEROS LDRAW DESDE BLENDER
Vamos al menú Archivo -> Importar -> LDraw (.mpd/.ldr/.l3b/.dat). En el panel de la derecha están las opciones que se van a usar:

Blender283-03.png

LDraw filepath: en ella escribimos la carpeta en la que tenemos guardadas las piezas en formato LDraw, por ejemplo, C:Tente.

Escala: por defecto es 0.01. Si las unidades de trabajo de Blender son centímetros, es mejor usar el valor 0.04, para que una jácena de 1 punto mida 8 mm de ancho.

Overall Look: la opción "Realistic Look" produce imágenes realistas, mientras que "Lego Instructions Look" produce un aspecto de manual, con colores lisos. La opción marcada aparece en color azul.

Add Environment: añade un suelo y una iluminación con zonas claras y oscuras. Si no se marca, la iluminación es la de una caja de luz blanca, como la que se usa en los productos de venta online.

Position the camera: si la marcamos el modelo quedará encuadrado y centrado en el campo de visión de la cámara que hace la foto virtual (render). En caso contrario luego tendríamos que colocar la cámara por nuestra cuenta.

Camera Border: sólo funciona si está activada la opción anterior. Es el porcentaje de hueco que habrá entre nuestro modelo y los contornos de la imagen. Por defecto es un 5%. Si ponemos valores negativos la cámara se acercará demasiado al modelo y algunas partes no saldrán en el render.

Colour scheme options: la opción "Realistic colours" usa colores optimizados por el autor del complemento. Las otras dos opciones, "Original LDraw colours" y "Alternate LDraw colours", son los colores que vienen con LDraw.

Resolution of part primitives: en las piezas de Tente apenas hay subpartes curvadas, así que no le afecta esta opción.

Smooth faces and edge-split: obligatoriamente tiene que estar marcada para que las caras curvas no salgan facetadas.

Bevel edges: si se marca, las aristas y los vértices aparecen algo redondeados (biselados), como en una pieza real. En la casilla "Bevel Width" se puede modificar el efecto de ese redondeado si nos parece escaso o excesivo.

Add space between each part: aunque las piezas reales dejan algo de hueco entre sí y eso ayuda a distinguirlas, a veces el biselado de la opción anterior es suficiente para distinguirlas y no hace falta marcar esta opción.

Use curved wall normals: abomba un poco las caras planas, parecido al de las piezas reales, y ayuda a distinguir piezas contiguas del mismo color.

Import cameras: no nos afecta, algo de cámaras creadas con el programa LeoCAD.

Link identical parts: si se activa, todas las piezas del mismo tipo y color son clones, lo que ahorra recursos en el ordenador. No es recomendable si luego vamos a hacer cambios de color o forma en una de esas piezas.

Include unofficial parts: no nos afecta
Show Lego...: no nos sirve, no marcar
Make individual studs: no nos sirve, no marcar

Put model on ground on origin: centra el modelo en las coordenadas de Blender y encima de un suelo (en MLCad no siempre se montan las cosas en el centro de coordenadas). Marcar si queremos tener el modelo sobre un suelo.

Number each object: no nos sirve salvo que luego se modifique el modelo en Blender. Numera cada pieza en el orden en el que aparece en el fichero LDraw.

Flatten tree: no marcar para que cada modelo se pueda manejar como una entidad en Blender.

Resolve Ambiguous Normals: tiene que estar marcada la opción "Recalculate Normals".

Aunque el programa se suele acordar de estos parámetros, podemos guardarlos bajo un nombre pulsando el botón + de la esquina superior derecha. Las próximas veces no tendremos que modificar estos parámetros y solo tendremos que seleccionar el fichero LDraw que queremos importar y pulsar el botón "Import LDraw Models".

ANTES DEL RENDER
Para ver qué es lo que está viendo la cámara virtual pulsamos el botón 0 del teclado numérico (en la parte derecha del teclado) o bien pulsamos el botón de la cámara que hay por la parte derecha del fondo gris. Una tercera opción es ir al botón Vista -> Punto de vista -> Cámara.

Blender283-04.png


Si nuestro ordenador tiene una tarjeta gráfica soportada por Blender, el render será más rápido. Entramos en el menú Editar -> Preferencias -> Sistema y en el apartado "Dispositivos de procesamiento de Cycles" seleccionamos las diferentes opciones hasta que encontremos listada nuestra tarjeta gráfica (CUDA y OptiX para tarjetas NVidia, OpenCL para las AMD). Si no aparece en ninguna, seleccionaremos la opción "Ninguno" que usará la CPU del ordenador y el renderizado será más lento (si tu tarjeta es vieja, podría ser compatible con Blender 2.79). Además de la GPU puede salir listada la CPU. Si marcamos ambos elementos del ordenador, los dos contribuirán en el renderizado repartiéndose el trabajo, pero si la CPU es más lenta que la GPU, entonces es mejor marcar solo la GPU para que el renderizado sea rápido. Cerramos el panel de preferencias. Estos pasos solo hay que realizarlos una vez.

Blender283-05.png

En el panel inferior de la derecha vamos a la tercera pestaña (icono de impresora, "Propiedades de salida"). En el parámetro "ResoluciónX Y" podemos cambiar el tamaño del render, que por defecto es 1920 x 1080 píxeles (calidad FullHD, unos 2 megapíxeles).

Blender283-06.png

Vamos a la segunda pestaña (icono cámara de fotos, "Propiedades de procesamiento") y en el apartado "Dispositivo" cambiamos a "GPU" si estaba como "CPU". Si la letra de GPU está apagada es que no reconoce nuestra tarjeta gráfica o hemos hecho algo mal en las preferencias. Más abajo, en el apartado "Muestreo" reducimos a 200 el valor de "Procesar". Cuanto más pequeño, menos tarda el render, pero más ruido puede aparecer en la imagen. Parte de ese ruido desaparece con un filtro que aplica Blender. El ruido afecta sobre todo a las zonas más oscuras.
En el apartado Muestreo marcamos la casilla de "Muestreo adaptativo", que evita gastar esas 200 muestras en zonas iluminadas. Después, en Trayectoria de rayos -> Rebotes máx, cambiamos el valor de Difusión, Reflectividad y Transmisión a 8. En el subapartado Iluminación reducimos la Iluminación indirecta a 4 (puede oscurecer el resultado y afectar a las piezas metalizadas).

Blender283-07.png

Más abajo está el apartado "Rendimiento". En las casillas "Repetición en X Y" cambiamos a 8 o 16 si estamos usando la CPU, mientras que para una tarjeta gráfica es mejor 128 o 256, salvo que nos aparezca un error por falta de memoria al renderizar. En ese caso reduciremos los valores a 64, 32, etc. Otra opción es activar el complemento "Render: Auto Tile Size", que viene de serie con Blender y nos escribirá automáticamente esos valores según su estimación.

Blender283-08.png

Además de la iluminación de fondo que ha añadido el propio complemento, en la escena hay un foco de luz que puso Blender al comienzo. Su posición no es la óptima y genera sombras duras, así que mejor eliminarlo o desactivarlo. En el panel superior de la derecha, encontraremos un listado con todos los elementos de nuestra escena. El foco de luz se llama "Light". Si queremos eliminarlo, pulsamos con el botón derecho encima de Light y seleccionamos la opción "Borrar". Para desactivarlo necesitamos añadir información a ese panel. Pulsamos en el icono del embudo y marcamos el icono de la cámara de fotos (el quinto por la izquierda). Con eso aparecerá ese icono además del ojo al lado de cada elemento del panel. Si desmarcamos la cámara de Light, no afectará a nuestra escena (el ojo es solo para ocultarlo de la vista previa).

Blender283-09.png

RENDER
Para que comience a generar el render pulsamos la tecla F12 o bien vamos al menú Procesar -> Procesar fotograma. Se abrirá una nueva ventana que se empezará a rellenar con cuadraditos del renderizado. En la parte superior nos indicará el tiempo que lleva en marcha y la estimación de lo que falta (remaining). Si queremos cancelar el render, pulsamos dos veces la tecla Escape o bien cerramos la ventana donde se está renderizando.

Blender283-10.jpg

Al finalizar, la información de la parte superior se resume al tiempo que ha tardado y la memoria que ha necesitado. Para guardar la imagen pulsamos en el menú Imagen -> Guardar como. Por defecto la guardará en formato PNG para no perder calidad, pero si queremos que sea un JPG, en la parte derecha del panel de guardado podemos cambiar el formato del archivo a "JPEG" y la calidad de la imagen. Cerramos la ventana del renderizado.

Blender283-11.jpg

Se puede modificar el contraste del render antes o después de su creación. Si ya existe, vamos a la pestaña Rendering para ver cómo le afectan los cambios. Si es antes del render, nos quedamos en la pestaña Layout en la que ya estamos. En el panel de la derecha (inferior derecha en Layout) entramos en la pestaña de la cámara de fotos (Propiedades de procesamiento) y al final encontraremos el apartado "Administración de color". En el desplegable "Retoque de apariencia" aparece "Ninguno" que es equivalente a "Medium Contrast". Todos los que son "high" aumentan el contraste de la imagen y los "low" lo reducen. El parámetro Exposición es el mismo que en las cámaras de fotos, tarda más o menos tiempo en tomar la foto de modo que con +1 se ve con el doble de luz y con el valor -1 es la mitad de la luz. Dentro de "Usar curvas" hay controles similares a los de programas de edición de fotos para afinar más la luminosidad de las zonas oscuras y claras.

Blender283-12.png

COLORES TENTE
Los colores que usa el complemento son los de las piezas de Lego. Para cambiar a unos más parecidos a los de Tente, seleccionamos por ejemplo una pieza blanca de nuestro modelo (clic con el botón izquierdo). En el panel de la derecha vamos a la penúltima pestaña (Propiedades de material) y pulsamos en el rectángulo blanco del parámetro Color.

Blender283-13.png

Pulsamos la tecla Hex y escribimos el nuevo valor F9F9F6. Para el resto de colores:
- Rojo: F61200
- Negro: 030303
- Verde: 006806
- Azul: 0064CB
- Scorpion: 241D07
- Amarillo: FFA012
- Gris: 6C6C6C
- Grafito: 1F1F1F


MOVER LA CÁMARA
La cámara y cualquier otro objeto giran respecto a un punto de referencia. En Blender puede ser el centro del mismo objeto o el cursor 3D (ese círculo de trazos rojos y blancos que inicialmente está en el origen de coordenadas). Aunque el modelo de Tente suele estar un poco por encima de ese cursor 3D, prefiero girar respecto a ese punto y luego desplazar la posición de la cámara para afinar.

Para que el punto de pivote sea el cursor 3D, pulsamos un botón de la parte superior (ver imagen debajo) y elegimos la opción "Cursor 3D".

Blender283-14.png

Si el cursor 3D no estuviese en el origen de coordenadas, podemos recolocarlo allí pulsando la letra C mayúscula. Generalmente se saldrá de la vista de la cámara, así que pulsamos el número cero en el teclado numérico para volver a tener la vista de la cámara. A continuación seleccionamos la cámara. Un método es hacer clic en el recuadro que rodea a nuestra escena (solo se ve en la vista cámara), pero es más fácil ir al panel de la derecha de las colecciones de la escena y hacer clic sobre "Camera". El recuadro se verá anaranjado.

Blender283-15.jpg

Pulsamos rz y movemos el ratón para girar la cámara en horizontal. Hacemos clic con el botón izquierdo para fijar la nueva posición de la cámara.
Pulsamos rxx para cambiar el ángulo vertical (de nuevo mover ratón y al final hacer clic). El comando rx lo haría respecto al eje X de coordenadas, mientras que rxx lo hace respecto a la horizontal de lo que ve la cámara.
Para afinar la posición de la cámara, la movemos pulsando la tecla g. Movemos el ratón para moverla hacia su derecha/izquierda y su arriba/abajo. Para acercar/alejar la cámara pulsamos gzz y movemos el ratón.
La cámara por defecto tiene una lente de 50 mm de distancia focal, que coge menos ángulo que las lentes de los móviles y los grandes angulares. En el panel de la derecha por debajo, la penúltima solapa tendrá el icono de una cámara de vídeo si seguimos teniendo seleccionada la cámara.

Blender283-16.png

Podemos cambiar la distancia focal a 28, que es la de los móviles, algunos incluso llegan a 24 (entra más en la foto, pero con más perspectiva). Según el valor que pongamos, nuestro modelo aparecerá más grande o pequeño en el encuadre, así que tendremos que alejar o acercar la cámara con el comando gzz. Si queremos eliminar totalmente la perspectiva, hay que cambiar el parámetro "Tipo" de "Perspectiva" a "Ortogonal". Entonces desaparecerá la distancia focal y habrá que modificar el parámetro "Escala ortogonal" para ver más grande o pequeño el objeto.

Si en lugar del centro de coordenadas queremos usar una pieza de nuestro modelo como centro del giro, seleccionamos esa pieza con el botón izquierdo del ratón y luego vamos al menú Objeto -> Adherir -> Cursor a seleccionado para que el cursor 3D se quede en ese objeto (en las piezas de Tente no siempre coincide con el centro de la pieza, sino con una esquina).

RENDERS MÁS RÁPIDOS
Como comenté en el apartado Render, si ponemos un número demasiado pequeño en el parámetro Muestreo, al final el ruido será tan evidente que incluso el filtro de ruido que aplica Blender por defecto no será suficiente y aparecerán parches en las zonas oscuras y poca nitidez en las zonas con detalles. Aún así, se pueden usar solo 16 muestras en lugar de las 200 si utilizamos otro filtro que viene incluido con Blender. En la quinta pestaña del panel derecho (Propiedades de capa de visualización) activamos la opción "Datos de reducción de ruidos" y desactivamos más abajo la de "Reducción de ruidos", que es la que hemos estado usando.

Blender283-17.png

En la parte superior entramos en la solapa Compositing y marcamos la casilla "Usar nodos". Automáticamente Blender nos añadirá dos nodos ya conectados entre sí. Podemos ver más grandes los nodos girando la ruleta del ratón.

Blender283-18.png

Arrastramos con el botón izquierdo el panel de la derecha, el de Composición, para dejar algo de hueco entre ambos nodos. En el menú superior pulsamos Agregar -> Filtrar -> Reducción de ruido.

Blender283-19.png

Nos aparecerá un nuevo nodo que sigue el movimiento del ratón. Lo colocamos encima de la línea que conecta los otros dos nodos y hacemos clic con el ratón para confirmar. Ahora tenemos tres nodos conectados, pero tenemos que crear dos uniones más entre los dos nodos de la izquierda. Hacemos clic en el circulito de Denoising Normal, arrastramos y soltamos el ratón en el circulito Normal del otro nodo. Lo mismo entre Denoising Albedo y Albedo.

Blender283-20.png

Ahora ya podemos pulsar F12 para generar el Render, que primero aparecerá con mucho ruido y al final del todo desaparecerá gracias al filtrado. Con el otro método, la reducción de ruido se aplica a medida que se van generando los cuadraditos del render. A continuación se ven las diferencias entre el método por defecto (izquierda) y el que usa los nodos (derecha):

Blender283-21.jpg

OCULTAR EL SUELO
En el panel superior de la derecha, el suelo se llama "LegoGroundPlane". Para que no se vea en el render desmarcamos el icono de la cámara de fotos. Si no se ve ese icono, pulsamos en el icono del embudo de ese panel y marcamos el icono de la cámara de fotos (el quinto por la izquierda). El icono del ojo solo oculta el suelo del panel en el que se edita, pero no lo oculta del render.

FONDO TRANSPARENTE
Se puede conseguir que el fondo sea transparente, para que no se vean los focos de luz. En el panel inferior de la derecha, entramos en la pestaña con el icono de la cámara de fotos (Propiedades de procesamiento) y en el apartado "Opciones de película" marcamos la opción Transparentar. Si a través de algún cristal se ve el fondo, también podemos transparentarlo marcando la opción Transparentar vidrios. Todo esto solo funciona cuando la imagen se guarda en formato PNG o TGA.

COLOR DEL SUELO
En el panel superior de la derecha seleccionamos el elemento "LegoGroundPlane". En el panel inferior entramos en la penúltima pestaña (Propiedades de material). Hacemos clic en el rectángulo blanco del parámetro Color y lo modificamos.
Si queremos que le suelo refleje algo, hay que cambiar el parámetro Superficie a "BDSF Reflectivo" y reducir el parámetro Rugosidad. Con el valor 0 es un espejo perfecto y con 1 no refleja nada.

CAMBIAR ILUMINACIÓN DE FONDO
El fondo por defecto es una imagen con focos, así que al cambiarla cambiará la iluminación. Está en la sexta pestaña del panel de la derecha (icono bola terrestre, Propiedades de entorno), en el parámetro Color. Desplegamos la información pulsando en el triangulito que hay a la izquierda. Para cambiar la imagen pulsamos en el icono de la carpeta y elegimos otra imagen, preferiblemente con la extensión hdr o exr.
Si en lugar de una imagen queremos un fondo de color, hacemos clic sobre "background.exr" o en el circulito que hay a su derecha. Seleccionamos "RVA" de la columna Entrada y después elegimos el color. Si la luz es excesiva o insuficiente, modificamos el parámetro Intensidad.

ETIQUETAS Y PEGATINAS
Vamos al menú Editar -> Preferencias -> Complementos. En la casilla de la lupa escribimos "image". Marcamos el único complemento que aparecerá listado: "Import-Export: Import Images as Planes". Cerramos el panel de preferencias. Este paso solo hay que hacerlo una vez.
Vamos al menú Agregar -> Imagen -> Images as Planes. Se abre un panel para elegir la imagen que vamos a usar. Pulsamos el botón "Importar i... como planos". Nos aparecerá la imagen en el punto donde está el cursor 3D (el círculo con trazos rojos y blancos). Podemos moverla, girarla y escalarla con las herramientas que hay en el panel izquierdo.

Nota final: si tienes dudas, regístrate en el foro de TENTEland y te ayudaremos a resolverlas.

Advertisement